geek space web solutions

Quelle version de PHP pour Joomla ?

Samedi, 28 Mai 2011 15:18
php joomla parse error
Il existe des différences importantes entre PHP4 et PHP5. "PHP5 n'est pas une révolution mais une évolution." Votre CMS a forcément des pré-requis à ce sujet... Je me permets dans cet article de faire un rappel sur les pré-requis de Joomla.


Tout d'abord voici un rappel concernant les changements majeurs de PHP5 par rapport à PHP4 :

  • SQLite: Un moteur SQL complet ou presque sans avoir recours à un système client/serveur.
  • SimpleXML: Un nouveau parseur XML plus efficace et plus simple.
  • Un nouveau modèle POO: Le modèle objet complètement remanié, probablement le changement le plus important.


Concernant Joomla, vous avez peut-être déjà obtenu ce genre d'erreurs :

Parse error: parse error, unexpected T_CLASS in C:\Program Files\wamp\www\*your_directory*\libraries\loader.php on line 18

Si vous obtenez le message d'erreur ci-dessus avec un Joomla 1.6, vérifiez votre version de PHP, vous avez certainement en PHP4, il vous faut du PHP5 !


Petit rappel :

Pour Joomla 1.5 : Version minimales pré-requises :
- PHP 4.3.10+ minimum
- MySQL 3.23.x minimum
- Apache 1.3 minimum

Pour Joomla 1.6 : Version minimales pré-requises :
- PHP 5.2.4+ minimum
- MySQL 5.0.4+ minimum
- Apache 1.3 minimum, 2.x recommandé


Soyez très vigilant sur les pré-requis de votre CMS, il doit être en adéquation avec votre environnement.
Cette règle est valable également avec des composants, modules ou plugins !
 

Ajouter un Commentaire


Code de sécurité
Rafraîchir

Sections


Sondages

Pensez-vous que le HTML5 puisse complètement remplacer Flash ?
 
Seriez-vous intéressé par un éditeur d'XML en ligne ?
 

Paypal

paypal

Code du plugin Joomla AutoSEO 1.2 par www.geek-space.fr